Commit 87e33726 authored by mohoff's avatar mohoff

fix(Dockerfile): pin alpine to v3.9 so that pinned deps installed next do not conflict

parent 3b915b3a
Pipeline #23356 passed with stages
in 20 seconds
###############
# BUILD IMAGE #
###############
FROM node:10-alpine as build
FROM node:10-alpine3.9 as build
WORKDIR /app
# Install alpine dependencies required for building native extensions for npm packages
RUN apk update && apk add --no-cache --virtual deps git=2.20.1-r0 python3=~3.6.9 make=4.2.1-r2 g++=8.3.0-r0 ca-certificates=20190108-r0
RUN apk update && apk add --no-cache --virtual deps git=2.20.1-r0 python3=3.6.9-r2 make=4.2.1-r2 g++=8.3.0-r0 ca-certificates=20190108-r0
{{#if strongConfig}}
# Install sops
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment